• Este debate tiene 5 respuestas, 3 mensajes y ha sido actualizado por última vez el hace 3 meses, 1 semana por dani.or.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)

Certificados Business Central 15



  • Jon Ander (IGN)
    Participante
    Jon Ander (IGN)

    Buenas,

    Estoy intentando realizar una llamada a un servicio web con certificado y al parecer, para añadir un certificado en la variable HttpClient, tiene que ser en Base64, he estado rebuscando un poco, y hay una tabla “Isolated Certificate” y una Codeunit “Certificate Management” que al parecer te devuelve el certificado en base64, y puedes utilizarlo en la variable HttpClient.

    El problema que tengo es el siguiente… Cuando llamo a la función “GetCertAsBase64String” de la Codeunit, me devuelve un error, que esta función no se puede utilizar en ese entorno, al ser BC15 lo estoy ejecutando con el cliente Web, y me he fijado que en la Codeunit, tiene puesto Scope[‘onPrem’], esto significa que solo funciona onPremise no?, hay algún otro método para que funcione en cliente web?

    Saludos.

    #1015915

    Joker
    Participante
    Joker

    Hola,

    Al tener la etiqueta “Scope[‘onPrem’]” solo se puede usar On-Premise, pero una alternativa que tienes es copiar esa función y ponerla en una nueva codeunit, de esta manera la podrías usar.

    #1016044

    Joker
    Participante
    Joker

    Te devuelvo la pregunta. Tengo que plantear un desarrollo que tiene que utilizar un certificado el cual encriptará un XML y este se enviará a un webservice. ¿Podrías darme alguna indicación de lo que has descubierto? Apenas he empezado.

    La principal pregunta que tendría es si has descubierto la manera de encriptar un fichero con el estándar XAdES.

    Gracias

    #1016045

    Jon Ander (IGN)
    Participante
    Jon Ander (IGN)

    Buenas Sergio,

    No me deja postear el mensaje, si quieres escríbeme por correo y te comento lo que he realizado, sigue sin funcionarme…

    mi correo: ja.garcia@ignsl.es

    Gracias.

    #1016058

    Joker
    Participante
    Joker

    Hola Jon,

    Yo también he tenido problemas a la hora de postear respuestas en el foro. Funciona pero hay cosas que no van bien, entre otras, el nº de respuestas que se ve en el listado de foros.

    Te envío un mail desde mi e-mail personal 😉

    #1016087

    dani.or
    Participante
    dani.or

    Hola,

    ¿Finalmente conseguiste encriptar el XML con XAdES desde Business Central?

    Yo necesito hacerlo también. De momento lo he conseguido hacer mediante esta libreria de .net, pero no me termina de quedar correcto. Y luego tendría que montar una Azure Function y realmente no estoy seguro de si es la mejor opción.

    Si me puedes dar alguna indicación te lo agradezco mucho.

    Gracias

    #1022801
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)

Debe iniciar sesión para responder a este tema.