• Este debate tiene 2 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 2 años, 3 meses por AvatarBleika.
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)

Respuestas del foro


  • Avatar
    Bleika
    Participante
    Bleika

    Hola a todos,

     

    Llevo varios días peleándome con el montaje de Docker EE en un WinServer 2016 (virtual) y no hay manera. Lo necesito para desarrollar para OnPrem y no está en Azure.

    Es un tema relacionado con redes (el servicio de Docker no arranca si no excluyo la creación de redes por defecto), que luego resulta en un contenedor de BC que no se conecta mi red ni obtiene IP (por lo que no me puedo conectar a él).

    Publiqué un post en MSDN, pero no ha habido suerte. Incluso contacté con FreddyK (autor de navcontainerhelper) pero, al ser un error previo a la generación del contenedor, no me pudo ayudar.

    ¿Hay algún participante aquí que se haya encontrado con el mismo problema?

    Agradecería enormemente cualquier pista…

    Saludos

    #6896
    Avatar
    Cristina Nicolàs
    Superadministrador
    Cristina Nicolàs

    HOla,

    Siento no ser de gran ayuda. Yo por suerte no he tenido excesivos problemas a la hora de utilizar Docker.

    Espero que lo encuentres.

    Un saludo,
    Cristina Nicolàs

    #6904
    Avatar
    Bleika
    Participante
    Bleika

    Gracias de todos modos Cristina,

    Esta madrugada recibí una pista a través de MSDN.

    Todavía me estoy peleando, pero al menos he conseguido reducir el número de errores. Por si Docker le da guerra a alguien más aquí, existe un script de análisis que me ha ayudado bastante:

    (PowerShell) Invoke-WebRequest https://aka.ms/Debug-ContainerHost.ps1 -UseBasicParsing | Invoke-Expression

    Documentación: https://docs.microsoft.com/en-us/virtualization/windowscontainers/troubleshooting

    Saludos

    #6906
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)

Debe iniciar sesión para responder a este tema.