Etiquetado: 

  • Este debate tiene 1 respuesta, 2 mensajes y ha sido actualizado por última vez el hace 1 año, 8 meses por AvatarLaura Nicolàs.
Viendo 2 entradas - de la 1 a la 2 (de un total de 2)

Respuestas del foro


  • Avatar
    Jon Ander (IGN)
    Participante
    Jon Ander (IGN)

    Buenas,

    Para descartar que sea problema estándar de Business Central….

    Os ha dado alguna vez error al crear un cliente? Cuando va a asignar el Nº de cliente, entra en bucle, pero como estoy en Business Central OnCloud, no se como poner el debugger o ver porque esta entrando en bucle todo el rato..

    Lo único que tengo es un evento en el OnInsert del cliente, que si tengo configurada una dimensión asociada al cliente, me cree esa dimensión y me la asigne al cliente en cuestión..

    Gracias.

    Saludos

    #8574
    Avatar
    Laura Nicolàs
    Superadministrador
    Laura Nicolàs

    Jon,

    No me ha pasado, pero tienes que poder poner el debugger de vscode y seguirlo.

    Para poner el debugger:
    – Tiene que ser un entorno Sandbox. En el entorno productivo (creo) que no dejan debugar.
    – En el app.json, tienes que tener la propiedad ShowMyCode=true , porque sino no ves tu código…
    – El parámetro NetFx40_LegacySecurityPolicy tiene que estar a falso en el fichero Microsoft.Dynamics.Nav.Server.exe.config

    Tenemos pendiente un curso de debugging desde vscode. Mientras tanto, te dejo algo de documentación: https://docs.microsoft.com/en-us/dynamics365/business-central/dev-itpro/developer/devenv-debugging

    Salut!
    Laura Nicolàs

    #8617
Viendo 2 entradas - de la 1 a la 2 (de un total de 2)

Debe iniciar sesión para responder a este tema.