• Este debate tiene 2 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 11 meses, 2 semanas por AvatarCristina Nicolàs.
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)

Respuestas del foro


  • Avatar
    Guinaz
    Participante
    Guinaz

    Estimadas Cristina y Laura,

    Estoy creando el layout de un Report (en Visual Studio Code y Dynamics Nav 2018), pero recibo el siguiente error (tanto desde el cliente de escritorio como desde el cliente web). ¿Qué estoy haciendo mal?

    #12901
    Avatar
    Cristina Nicolàs
    Superadministrador
    Cristina Nicolàs

    Hola Alfonso,

    Entiendo por otra pregunta que has hecho en el foro que el report 50100 lo has creado desde Visual Studio Code y ahora lo quieres utilizar en el cliente, seguramente con la funcionalidad de Layouts personalizados para generar un layout.
    Si dice que no se encontró el report con id. 50100, es posible que sea porque no esté publicada la extensión.
    O que el report tenga la propiedad de ProcesingOnly a true. Si es de solo proceso no tiene layout. Y si no tiene layout no lo vas a encontrar en esta funcionalidad de layouts personalizados.

    Un saludo,
    Cristina Nicolàs

    #12910
    Avatar
    Cristina Nicolàs
    Superadministrador
    Cristina Nicolàs

    Hola Alfonso,

    Me alegra que lo hayas podido solucionar.

    De todos modos, no creo que sea por eso que comentas. Porque de hecho, la propiedad RDLCLayout te estaba dando un error que no te permitía crear el paquete ni publicarlo. De modo que en realidad en Navision estaba publicado un código anterior. Un código que no tenía el RDLCLayout.

    Te comentaba lo de ProcessingOnly porque a mi me pasó en más de una ocasión. Durante este ejercicio, primero creaba el report como ProcesingOnly y lo publicaba.
    Después en el código, por mucho que le quitara el ProcesingOnly (y por tanto estar convencidísima que no era ya de proceso), no publicaba este cambio, y la BBDD en realidad tenía publicado el código anterior (que sí era ProcesingOnly). Y cada vez que me pasó que no encontraba mi report en esta funcionalidad de layouts personalizados era por el ProcessingOnly.

    Un saludo,
    Cristina Nicolàs

    #12922
Viendo 3 entradas - de la 1 a la 3 (de un total de 3)

Debe iniciar sesión para responder a este tema.