• Este debate tiene 5 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 1 año, 6 meses por AvatarLaura Nicolàs.
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)

Respuestas del foro


  • Avatar
    BETEA
    Participante
    BETEA

    Buenos días,

    Hace unos días, salio una imagen nueva para el despliegue de Bussines Central en un docker. Llevaba ya días que no me funcionaba mi docker, con el error de que la versión era antigua. Intente realizar «pull» con la nuevas imagen sobre el docker, pero no me actualizaba la versión.

    Por ello, decidí eliminar el docker existente, y crear uno nuevo con la última imagen. A priori parece que funciona correcto, de hecho las extensiones se publican correctamente, pero el cliente web no funciona. En cambio el cliente windows si. He intentado hacer «restart» del docker, y aparentemente todo está correcto:

    Como he comentado, el cliente windows funciona, pero el web no, tanto al intentarlo abrir manualmente, o al hacer un deploy de una extension creada:

     

     

    Alguna idea? Siemrpe podría eliminar el docker, y crear uno nuevo, pero con el riesgo de que me pueda volver a ocurrir lo mismo, y que no sepa como solucionarlo…

    Muchas gracias

    #7345
    Avatar
    Laura Nicolàs
    Superadministrador
    Laura Nicolàs

    Hola,

    Veo que la instalación es con autenticación NavUserPassword.
    Te ha pedido usario y contraseña al entrar al cliente web? Le estas poniendo los valores que tocan? (seguro que si, pero lo tenía que preguntar…)
    Has verificado que el usuario existe en la base de datos y tiene permisos? (lo podrías consultar via PowerShell, o a través del cliente de escritorio).

    Si con esto no consigues entrar, te diria que lo preguntaras en el foro de GitHub…

    Salut!
    Laura Nicolàs

     

     

     

    #7361
    Avatar
    BETEA
    Participante
    BETEA

    Muchas gracias Laura,

    No me llega ni siquiera a pedir el usuario y contraseña, asique complicado…

    Como bien dices, preguntare en gitHub, me van a acabar cogiendo mania… De hecho, voy a pedir mi primer evento, o al menos, que me cambien un parametro en un evento existe. A ver si hay suerte…

     

    Un saludo!

    #7363
    Avatar
    BETEA
    Participante
    BETEA

    parece que no soy el unico…..

     

    https://github.com/Microsoft/nav-docker/issues/287

    #7364
    Avatar
    BETEA
    Participante
    BETEA

    Solucionado en el hilo que he copiado! Parece ser un problema bastante global y aleatorio.

    #7365
    Avatar
    Laura Nicolàs
    Superadministrador
    Laura Nicolàs

    Genial, gracias por actualizar el hilo.

    Salut!
    Laura Nicolàs

    #7371
Viendo 6 entradas - de la 1 a la 6 (de un total de 6)

Debe iniciar sesión para responder a este tema.