Etiquetado: , ,

  • Este debate tiene 3 respuestas, 2 mensajes y ha sido actualizado por última vez el hace 8 meses, 1 semana por oscarmingte.
Viendo 4 entradas - de la 1 a la 4 (de un total de 4)

Rendimiento Layout RDLC personalizado



  • proyectoerp
    Participante
    proyectoerp

    Buenas, llevo un tiempo con un problema al que no logro darle solución, a ver si alguien me puede echar un cable:

    Se trata de una modificación del Layout RDLC de nuestro informe de albaranes de venta, una modificación sencilla, simplemente ocultar información innecesaria en el diseño, ninguna modificación de dataset requerida, he importado el diseño  una vez personalizado  y lo he seleccionado, el problema es que al ejecutar el informe, ha pasado de tardar unos 3 segundos en ejecutarse a más de 40 tras la modificación, alguien sabe qué puede estar pasando?

    muchas gracias y un saludo

    #1021298

    oscarmingte
    Participante
    oscarmingte

    Hola , ¿lo ocultas a través de un check que cargas desde nav?¿el informe tiene imágenes en la cabecera? si tiene imágenes revisa si las estas cargando al principio del report o por cada registro, lo que puedes hacer es ir ocultando campos hasta que des con el que esta mal , para poder ayudarte mejor deberías poner el informe o dar más información.

     

    Un saludo.

    #1021306

    proyectoerp
    Participante
    proyectoerp

    Buenas Oscar,

    Primero gracias por contestarme, igual no me explico muy bien porque no soy técnico y mi conocimiento es más bien limitado.

    No termino de entender lo del check que me dices, lo que hago es importar el RDLC en diseño de informes personalizados, imágenes no hay en el documento, lo extraño de todo esto es que el original tiene los mismos campos, lo único que hago es  desplazar un par de columnas en el layout del informe para que no se vean

    #1021357

    oscarmingte
    Participante
    oscarmingte

    Hola , sin verlo es muy complicado ayudarte , si quieres (no se si se puede) adjunta el informe por aquí , por lo que comentas mueves las columnas no las ocultas con la propiedad ¿estas ejecutando el informe con los mismos filtros que antes de modificar?

     

    Un saludo.

    #1021412
Viendo 4 entradas - de la 1 a la 4 (de un total de 4)

Debe iniciar sesión para responder a este tema.