• Este debate tiene 1 respuesta, 2 mensajes y ha sido actualizado por última vez el hace 1 año, 4 meses por AvatarLaura Nicolàs.
Viendo 2 entradas - de la 1 a la 2 (de un total de 2)

Respuestas del foro


  • Avatar
    cayetano
    Participante
    cayetano

    Buenos días Laura y Cristina,

    Estoy haciendo un Upgrade de NAV2018 CU2 a BC2018 CU2 apoyándome en vuestro curso y notas técnicas de Microsoft, y cuando llego a la tarea 11 de Ejecutar la Sincronización del Esquema con Validación de todos los objetos importados, se para para que ejecute Sync-NAVTenant DynamicsNAV130 -Mode CheckOnly y no me da ninguna información de error como en otras ocasiones.

    En el campo de DetailedState a través del comando Get-NAVTenant -Serverinstance ‘DynamicsNAV130’ da la siguiente información:

    State : OperationalWithSyncPending
    DetailedState : Tenant default in database BC2018CU2_XXXXXX (application version
    11.0.20348.0) cannot be used. The tenant can be brought to the operational
    state by synchronizing the database.

    Pude llegar a NAV2018CU2 con los problemas habituales, pero funciona bien, pero después lo he intentado tanto con BC2018 CU2 como CU6 en distintas máquinas y llego al mismo error, avanza en la sincronización de esquema y en la tarea 4 de 8 de 2 de 55 tablas se detiene y no obtengo más información.

    Cualquier ayuda será de agradecer ya que este problema nos tiene detenidos.

    Muchas gracias.

    Un cordial saludo.

    #10908
    Avatar
    Laura Nicolàs
    Superadministrador
    Laura Nicolàs

    Hola Cayetano,

    El sync también me da dado problemas en ocasiones…

    Yo siempre lo hago desde PowerShell, y si algo no va, voy probando con todas las combinaciones posibles de parámetros

    $NavService = «BC130»
    Sync-NAVTenant -ServerInstance $NavService -Verbose
    Sync-NAVTenant -ServerInstance $NavService -Force #-Verbose
    Sync-NAVTenant -ServerInstance $NavService -Mode CheckOnly -Verbose
    Sync-NAVTenant -ServerInstance $NavService -Force #-Verbose
    Sync-NAVTenant -ServerInstance $NavService -Mode ForceSync #-Verbose
    Sync-NAVTenant -ServerInstance $NavService -Force -Mode ForceSync #-Verbose

    Si con alguna de las anteriores no me funciona entonces, como la compilación también sincroniza:

    – Voy a C/SIDE, compilo todas las tablas
    – Si no me ha funcionado, voy compilando las tablas una a una (o en bloques de 100), hasta encontrar el problema
    – Al final vuelvo a ejecutar el sync desde Powershell.

    Espero que te sirva.

    Salut!
    Laura Nicolàs

    #10920
Viendo 2 entradas - de la 1 a la 2 (de un total de 2)

Debe iniciar sesión para responder a este tema.